Jump to content
v10.11.2 Is Here: Free Agent-Based Backup for Proxmox and More! ×
NAKIVO Community Forum

Restoring to a host with less RAM


rimbalza

Recommended Posts

Hi, I'm using 10.8 on Linux to backup VMs from HyperV.

I have several VMs with a lot of RAM like 32 or 48 Gb. When I test my restores I cannot use as a destination an host with less ram than the original VM.

For example I want to restore a VM that has 48 gb of RAM on a host that has 32 GB. The process does not even start, it blocks the configuration procedure saying the host needs more RAM. I find no way to say to resize the RAM or continue anyway.

This is an horrible design decision for at least a couple of reasons:

- In my case I just restore the VMs and do NOT power them on, there's an option for that. Still Nakivo says I cannot restore.

- In an emergency this requires you to have a full set of working hosts with at least the same RAM as you had before, and this again is an awful decision that hinders the ability to use Nakivo for real world recovery scenarios.

I am in charge of the restore and if I decide to restore to an host with less RAM than the original one it should be my problem. I understand a warning from Nakivo, I cannot understand why blocking the restore. On HyperV you can create any number of VMs with any amount of RAM, then you decide which one to start or to resize. Reducing the restore options for no pratical benefit and imposing artificial limits is just silly.

Is there a way to force Nakivo to continue the restore?

Thanks

 

  • Like 1
Link to comment
Share on other sites

3 hours ago, rimbalza said:

Hi, I'm using 10.8 on Linux to backup VMs from HyperV.

I have several VMs with a lot of RAM like 32 or 48 Gb. When I test my restores I cannot use as a destination an host with less ram than the original VM.

For example I want to restore a VM that has 48 gb of RAM on a host that has 32 GB. The process does not even start, it blocks the configuration procedure saying the host needs more RAM. I find no way to say to resize the RAM or continue anyway.

This is an horrible design decision for at least a couple of reasons:

- In my case I just restore the VMs and do NOT power them on, there's an option for that. Still Nakivo says I cannot restore.

- In an emergency this requires you to have a full set of working hosts with at least the same RAM as you had before, and this again is an awful decision that hinders the ability to use Nakivo for real world recovery scenarios.

I am in charge of the restore and if I decide to restore to an host with less RAM than the original one it should be my problem. I understand a warning from Nakivo, I cannot understand why blocking the restore. On HyperV you can create any number of VMs with any amount of RAM, then you decide which one to start or to resize. Reducing the restore options for no pratical benefit and imposing artificial limits is just silly.

Is there a way to force Nakivo to continue the restore?

Thanks

 

Hello, @rimbalza, your information/request has been received and forwarded to our Level 2 Support Team. Meanwhile, the best way for both sides would be to generate and send a support bundle (https://helpcenter.nakivo.com/display/NH/Support+Bundles) to support@nakivo.com so our Technical Support team can investigate your issue having more details.

Thank you for understanding.

Link to comment
Share on other sites

5 hours ago, rimbalza said:

Hi, I'm using 10.8 on Linux to backup VMs from HyperV.

I have several VMs with a lot of RAM like 32 or 48 Gb. When I test my restores I cannot use as a destination an host with less ram than the original VM.

For example I want to restore a VM that has 48 gb of RAM on a host that has 32 GB. The process does not even start, it blocks the configuration procedure saying the host needs more RAM. I find no way to say to resize the RAM or continue anyway.

This is an horrible design decision for at least a couple of reasons:

- In my case I just restore the VMs and do NOT power them on, there's an option for that. Still Nakivo says I cannot restore.

- In an emergency this requires you to have a full set of working hosts with at least the same RAM as you had before, and this again is an awful decision that hinders the ability to use Nakivo for real world recovery scenarios.

I am in charge of the restore and if I decide to restore to an host with less RAM than the original one it should be my problem. I understand a warning from Nakivo, I cannot understand why blocking the restore. On HyperV you can create any number of VMs with any amount of RAM, then you decide which one to start or to resize. Reducing the restore options for no pratical benefit and imposing artificial limits is just silly.

Is there a way to force Nakivo to continue the restore?

Thanks

 

@rimbalza We extend our gratitude for choosing NAKIVO Backup & Replication software and your keen interest in optimizing your operational efficiency.

In response to your query, we would like to draw your attention to a pivotal feature within our software's system settings. The "Check for sufficient RAM on the target host for replication/recovery jobs" checkbox is a significant consideration for ensuring seamless replication and recovery processes: https://helpcenter.nakivo.com/User-Guide/Content/Settings/General/System-Settings.htm  

Please note that this checkbox may be enabled or disabled based on your operational preferences. We encourage you to review your system settings and assess whether this option aligns with your current requirements. Should you require further clarification, assistance in configuration, or have additional inquiries, our dedicated support team is readily available to provide the guidance you need.

Thank you for choosing NAKIVO Backup & Replication to enhance your data protection and management endeavors.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...